Premium membership not recording premium ranks for my guild

Post Reply
UnshackledRev
Posts: 2
Joined: Thu Jan 02, 2014 6:22 pm

Premium membership not recording premium ranks for my guild

Post by UnshackledRev » Thu Jan 02, 2014 6:33 pm

Hello there!
I recently upgraded my guild's world of logs account to a "Pro" account. It was my understanding that this would allow our raiders to be able to rank up to #250, however following last night's raid and several of our players doing the DPS/HPS required to rank, none of them received any ranks on heroic bosses. Initially I opted to wait due to the warning about the ranks potentially taking 12 hours to be sorted out, however almost 21 hours on now, and any of our raiders still have yet to receive any ranks on HC bosses.

Bellow is an example of this, myself being Draekan doing 345741.1 effective DPS on Fallen Protectors Heroic encounter:
http://www.worldoflogs.com/reports/rt-o ... 775&e=1314

According to the ranking on the World of Logs page (http://www.worldoflogs.com/rankings/pla ... in/?page=5) this should put me around about rank 189 for Fallen Protectors HC. However I have neither received said rank, nor am I even listed on the page as having ranked at all on that fight.

I'm somewhat new to the whole premium thing, and I also noticed it says when I upload a report "Premium rankings are hidden", why is this? Is there any way to show them? And why have our players not ranked at all?
Thanks very much for your time,
Draekan

UnshackledRev
Posts: 2
Joined: Thu Jan 02, 2014 6:22 pm

Re: Premium membership not recording premium ranks for my gu

Post by UnshackledRev » Thu Jan 02, 2014 6:44 pm

Ok, I think I may have managed to sort it.
Am I correct in assuming that the reason Premium Rankings were not shown is due to the fact that Disable premium rankings was previously set to "Yes" under Manage Guild in the roll-out from my Guild's name? Seems like a fairly obvious question, but will that have solved my problem?
Thanks very much! :D

Post Reply