Bug: Java Client Mac Support

Locked
Ninjapest
Posts: 7
Joined: Mon Apr 13, 2009 1:02 am

Bug: Java Client Mac Support

Post by Ninjapest » Mon Apr 13, 2009 1:33 am

Dunno if this is something i'm doing wrong or rather not doing, or that isn't possible yet, but after downloading the client and running it, I am unable to enter my username and password in the preference pane and save it, and therefore progress any further with setup/upload.

I am able to upload on my mac under bootcamp through xp.

Maihem
Site Admin
Posts: 2747
Joined: Sun Apr 05, 2009 4:14 pm

Re: Bug: Java Client Mac Support

Post by Maihem » Mon Apr 13, 2009 2:05 am

How exactly are you unable to enter your credentials? Does the form show? Are there text fields? Can you type in them? Also, what version of OS X are you using?

If you can provide some more specifics, I'll see about setting up a VM to try and reproduce the bug.

Miles
Site Admin
Posts: 1526
Joined: Mon Mar 30, 2009 7:12 pm

Re: Bug: Java Client Mac Support

Post by Miles » Mon Apr 13, 2009 2:38 am

I'll poke Albert tomorrow to see if we can reproduce it, easier that way, no need to mess with VM's, that Mac he bought is useful after all.

(Hey, you Mac guys make fun of PC's all the time :P)

Ninjapest
Posts: 7
Joined: Mon Apr 13, 2009 1:02 am

Re: Bug: Java Client Mac Support

Post by Ninjapest » Mon Apr 13, 2009 7:43 pm

Is OS X 10.5.6, yes the box shows up to put my account details in, and i can enter them and hit test/save, but when i do it appears to "hang", left it for 10 minutes or so and tried it a couple of times, but it didn't do anything, and if i exit the preference pane and re-enter it, my details are no longer there.

Also, the set the log file bit doesn't work as it should, when i enter a folder path or such, or when i click find/test, it "hangs" up, but managed to set one by clicking through the load file option on the main log window, by clicking the middle option.

Miles
Site Admin
Posts: 1526
Joined: Mon Mar 30, 2009 7:12 pm

Re: Bug: Java Client Mac Support

Post by Miles » Mon Apr 13, 2009 8:12 pm

I think I've found the cause - at least on Albert's Mac - it's running Java 1.5 by default. Quite a few things we use depend on using a recent version of Java, I believe that the minimum is Java 1.6. Open Java Preferences, and make sure it uses "Java SE 6" as default.

And there's something else, which I can't seem to pinpoint at the moment... Hmm.

gd1107
Posts: 2
Joined: Mon Apr 13, 2009 11:02 pm

Re: Bug: Java Client Mac Support

Post by gd1107 » Mon Apr 13, 2009 11:03 pm

that would explain why it didn't work in Linux either...

Miles
Site Admin
Posts: 1526
Joined: Mon Mar 30, 2009 7:12 pm

Re: Bug: Java Client Mac Support

Post by Miles » Mon Apr 13, 2009 11:14 pm

Yeah. While java is "platform independent", there is still room for improvement. They ship with different versions and with other quicks when it comes to file system access, so for the moment, assume the client is Windows + Java 1.6.0_13 only.

We'll start testing other OS after things have settled down a bit, but I can't guarantee a time to fix. So much to code, so little time...

Ninjapest
Posts: 7
Joined: Mon Apr 13, 2009 1:02 am

Re: Bug: Java Client Mac Support

Post by Ninjapest » Tue Apr 14, 2009 12:40 am

Fix worked, thank you Maihem and miles.

Keep up the awesome work, looking forward to using this full-time over wws and wmo ;)

Miles
Site Admin
Posts: 1526
Joined: Mon Mar 30, 2009 7:12 pm

Re: Bug: Java Client Mac Support

Post by Miles » Tue Apr 14, 2009 1:45 am

Good to hear that. I think I made a newbie mistake while testing - entered my username with lower case - and assumed it just didn't work. I didn't want to mess up Albert's mac by installing a whole IDE to debug the thing :lol:

Locked