[SOLVED] Unable to Launch Client

Posts: 2
Joined: Thu Nov 08, 2012 7:53 pm

[SOLVED] Unable to Launch Client

Post by Adalwolf » Thu Nov 08, 2012 7:57 pm

I am using the client downloaded from the website, not a stored one. I also tried re-installing Java, but still get an error. Client worked well previously. Any help is appreciated. Thank you.

Code: Select all

<jnlp spec="6.0+" href="http://media.worldoflogs.com/media/client/client-4.2.jnlp" codebase="http://media.worldoflogs.com/media/client/client-4.2/">
    <title>World of Logs Client (4.2)</title>
    <vendor>Digibites Technology</vendor>
    <homepage href="http://www.worldoflogs.com/"/>
    <description>Client application used to upload WoW combat logs to World of Logs.</description>
    <icon href="logo-wide.jpg" kind="splash"/>
  <update check="always"/>
    <j2se version="1.6+" initial-heap-size="128M" max-heap-size="400M" java-vm-args="-Xms128M -Xmx400M -XX:MaxPermSize=96m"/>
    <jar href="WOL3.jar" main="true"/>
    <jar href="lib/commons-codec-1.6.jar"/>
    <jar href="lib/commons-logging-1.1.1.jar"/>
    <jar href="lib/commons-primitives-1.0.jar"/>
    <jar href="lib/httpclient-4.2.1.jar"/>
    <jar href="lib/httpcore-4.2.1.jar"/>
    <jar href="lib/httpmime-4.2.1.jar"/>
    <jar href="lib/jgoodies-common-1.2.0.jar"/>
    <jar href="lib/jgoodies-forms-1.4.1.jar"/>
  <application-desc main-class="com.wol3.client.forms.OpenFileOrCombatLogForm"/>

Code: Select all

java.lang.ClassNotFoundException: com.wol3.client.forms.OpenFileOrCombatLogForm
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at com.sun.jnlp.JNLPClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
	at com.sun.javaws.Launcher.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Posts: 2
Joined: Thu Nov 08, 2012 7:53 pm

Re: Unable to Launch Client

Post by Adalwolf » Fri Nov 09, 2012 5:03 am

Fixed my issue by following the "Restore JNPL File Association" instructions found viewtopic.php?f=22&t=1994#p9199

Posts: 1517
Joined: Wed Aug 26, 2009 7:56 pm

Re: [SOLVED] Unable to Launch Client

Post by ArcaneMagus » Mon Dec 17, 2012 8:30 pm

Thanks for posting back with your solution and I'm glad you were able to get it solved ;)